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Datum Features 

Introduction 

Datum features are non-solid features used during the construction of other features. The most 
common datum features include planes, axes, coordinate systems, and curves. Datum features do 
not add or remove material from the model and therefore do not affect the mass properties of the 
model. Some datums, such as axes, have ‘name tags’ as shown below. 

Datums are created using the Insert menu or the Datum toolbar as shown below on the left. 
Some datum curves such as projected, wrapped, and intersected, are created using the Edit 
menu. 

The display of datum features can be toggled on/off using the Datum Display toolbar, located at 
the top of the user interface and shown below on the right. The display of datum features can 
also be toggled on/off using View, Hide or by using Layers. 
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Datum Plane 

The most common datum feature is the datum plane. All parts should have three default datum 
planes as the first three features. Additional datum planes can be created using the Datum 
toolbar, shown below, or can be created ‘on the fly’ during the creation of other features. Datum 
planes created ‘on the fly’ are separate features and are automatically hidden by the system. See 
page 150 for details about the Hide command. 

Datum planes can be created using combinations of these options: 

• Offset from an existing datum plane or planar surface. 
• Through an axis, edge, or curve. 
• Normal to an existing datum plane or planar surface. 
• Parallel to an existing datum plane or planar surface. 
• At a specified angle to an existing datum plane or planar surface. 
• Tangent to a cylindrical surface. 

Datum planes are used for: 

• The first three features in all parts and assemblies. 
• Sketching plane and reference plane for sketching. 
• Dimensioning and alignment references in the sketch. 
• Feature references when using the ‘To Selected’ depth option. 
• Creating cross-sections. 
• Reference plane for the mirror command. 
• Geometric tolerances, drawing view orientation. 
• Assembly placement constraints. 

FRONT
TOP 

RIGHT

Datum planes are the first
three features in every model

Click here to create
datum planes
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The Datum Plane Dialog Box 

The Datum Plane dialog box is used to create datum planes. Select the references for the datum 
plane before selecting the Datum Plane icon, shown above. For example, to create an offset 
datum plane, select the plane to offset from first, then click the icon. 

The Datum Plane dialog box has three tabs and is shown below. 

 

The right mouse
button popup menu

is shown here

Use the Display tab to 
flip the positive/negative 
side of the datum plane 

When creating an offset 
datum plane, enter the 
offset value here 

Fit the datum 
plane here 

Enter the name for 
the plane in the 
Properties tab 

When using an edge and a plane for
the references, use this pull down

menu to select the type of plane

Enter angular rotation here
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Datum Axis 

Another common datum feature is the datum axis. Datum axes are created automatically during 
creation of a hole or revolved feature. Datum axes can be created using the Datum Toolbar as 
shown below. Select the references for the axis first, then click the icon in the toolbar. 

Datum axes can be created using combinations of these options: 

• Through a linear edge. 
• Normal to a datum plane or planar surface. 
• Through a datum point. 
• Through the center of a cylindrical surface. 
• At the intersection of two datum planes or planar surfaces. 

Datum axes are used for: 

• Creating coaxial holes. 
• Centerlines on drawings. 
• To indicate symmetry on drawings. 
• Geometric tolerances. 
• Assembly placement constraints. 

Datum axes are automatically 
created at the center of 
revolved features and at the 
center of holes 
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Click here to create
datum axes
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The Datum Axis Dialog Box 

The Datum Axis dialog box is used to create datum axes. Select the references for the axis 
before selecting the Datum Axis icon, shown above. For example, to create an axis at the 
intersection of two planes, select the two planes first, then click the icon. To create an axis 
normal to a plane, select the normal plane first, then click the Datum Axis icon, then use the 
right mouse button popup menu to select the offset references. 

The Datum Axis dialog box has three tabs and is shown below. 

The right mouse
button shortcut menu

Enter a name for the axis 
in the Properties tab 

When creating an 
axis normal to a 
plane, the normal 
plane is listed here 
 
Enter the offset 
values here 
 
Use the Display tab 
to set the size of the 

axis display
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Datum Coordinate System 

Pro/ENGINEER is not an XYZ based CAD system, however, datum coordinate systems can be 
created using the Datum toolbar or the Insert menu. The ‘default coordinate system’ is a special 
feature located at the intersection of the three default datum planes and can only be created using 
the Insert menu. The template part includes a default coordinate system. 

Pro/ENGINEER coordinate systems are ‘right-handed’: using your right hand, the thumb is the 
positive X axis, the index finger is the positive Y axis, and the middle finger is the positive Z 
axis as shown below. 

Datum coordinate systems can be created using these options: 

• At the intersection of the three default datum planes. 
• At the intersection of three datum planes or planar surfaces. 
• Offset from another coordinate system by translate and / or rotate. 

Datum coordinate systems are used for: 

• Measurements. 
• Exporting the model to IGES or 

other file types. 
• Assembly constraints. 

Click here to create datum 
coordinate systems

Right Hand Coordinate System

Y 

X Z
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The Coordinate System Dialog Box 

The Coordinate System dialog box is used to create all types of datum coordinate systems. 
Select the references for the coordinate system before selecting the icon. For example, select 
three planes first then click the Coordinate System icon. 

The Coordinate System dialog box has three tabs and is shown below. 

Use the Properties tab 
to enter a name for the 
coordinate system 

The Origin tab lists 
the references for 
the coordinate 
system and any 
offset values 
 
The Orientation tab 

is used to Flip the 
axes of the CSYS
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Sketches and Datum Curves 

Datum curves are wireframe geometry with no mass or volume similar to the Sketch feature. 
Sketches and datum curves can be lines, arcs, circles, and splines. Closed loop sketches can be 
crosshatched. Sketches and datum curves are created using the Datum Toolbar as shown below. 
Some datum curves are also created using the Edit menu. 

Datum curves can be created using a variety of methods: 

• At the intersection of two surfaces 
• Projected onto surfaces 
• Wrapped onto surfaces 
• Through points 
• Using the boundary of a surface 
• Offset from existing datum curves 
• From a file defining points 
• From an equation 
• Using a cross-section boundary 

Some uses for datum curves and sketches are: 

• References for other features (trajectory for sweep feature) 
• Skeleton parts 
• Represent other geometry 
• To define keep-out areas of a part 
• To create labels 
• To create a ‘filled’ area 
• Any kind of layout 
• To break up complex sketches into several simple sketches 

Datum curves and 
sketches can be used to 
create labels and 
‘filled’ areas

Click here to create a sketch

Click here to create 
datum curves
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Line Style of Datum Curves and Sketches 

Datum curves and sketches can have alternate line styles and colors applied to affect their 
display on screen and during printing or plotting. Select the curves then click Edit, Properties. 
The Line Style dialog box is used to select the Line Font and Color of the datum curve as 
shown below. 

Select the Line Font here 
and see the examples below 

Click here to change the color 
then select from the Color 
window 

Solid 
Dotted 
Centerline 
Phantom 
Dashed 
Intermittent 

Pro/ENGINEER Line Fonts
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The Insert Menu 

The Insert menu can be used to create datum features. For example, click Insert, Model 
Datum, Plane to create a datum plane. The Insert menu is shown below. 

 

Click here to create datum planes 
 
Create coordinate systems here 
 
Create datum curves here 
 
Create special types of datums 
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Using the Hide Command 

Individual datum features, such as a single datum plane, can be ‘hidden’ using the View, Hide 
command. This is similar to using Layers to ‘hide’ the object.  

Select the object(s) to be hidden, then click View, Visibility, Hide, or click the appropriate icon. 
The Hide and Unhide icons, shown above, can be added to the interface using the Tools, 
Customize Screen command. 

The right mouse button popup menu can be used in the model tree to ‘hide’ datum features. 
Selected features can be ‘unhidden’ using the View, Visibility, Unhide command. Click View, 
Visibility, Unhide All to unhide all objects in the current model that are hidden. 

Hidden features have a different icon in the model tree as shown below. 

This feature is ‘hidden’ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In the model tree, press and 
hold the right mouse button 
and click Hide or Unhide 
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Datum Name Tags 

Datum features have name tags associated with them. The 
display of these name tags is controlled using the View, 
Display Settings, Datum Display command or the icons 
shown below. These icons can be added to the user 
interface using the Tools, Customize Screen command. 

The Datum Display dialog box is shown here. 
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EXERCISE 6 - DATUM FEATURES 

Goal 

The goal of this exercise is to become familiar with creating datum 
features. 

Task 1: Create a datum plane in 4455-008. 

• Open the part called ‘4455-008.prt’  

• Click View, Orientation, Standard Orientation 

• Select the RIGHT datum plane 

• Click Insert, Model Datum, Plane or click the icon 

• Enter < 7 > for the offset value in the Datum Plane dialog box then click OK 

• The result is shown below (DTM1) 

• Save the part 

• Click File, Close Window 

 

TOP

FRONT

RIGHT

DTM1
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Task 2: Create datum features in 4455-004. 

• Open the part called ‘4455-004.prt’ 

• Select the FRONT datum plane 

• Click Insert, Model Datum, Plane or click the icon 

• Enter < -14 > for the offset value in the Datum Plane dialog box then click OK 

• The result is shown below (DTM1) 

• Select the RIGHT datum plane 

• Press and hold the CTRL key and select the DTM1 datum plane 

• Click Insert, Model Datum, Axis or click the icon 

• The result is shown below (A_1) 

• Set the selection filter to Geometry 

• Select this surface in this location 

• Click Insert, Model Datum, Axis or click the icon 

• In the graphics area, drag each of the two ‘drag handles’ and ‘snap’ them onto the 
RIGHT datum plane and the FRONT datum plane 

• Double click the dimension to the RIGHT datum and enter < 10.5 > for the value 

• Double click the dimension to the FRONT datum and enter < 11.5 > for the value 

• Click OK in the Datum Axis dialog box 

TOP

 
FRONT

RIGHT

DTM1

A_1 
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• The result is shown below (A_2) 

Notes 

The location where the placement plane is selected determines the 
positive direction of the locating dimensions. 

Using a negative value for the locating dimension moves the feature to the 
opposite side of the reference. 

• Save the part 

• Click File, Close Window 

Task 3: Create datum features in 4455-005. 

• Open the part called ‘4455-005.prt’ 

• Set the selection filter to Geometry 

• Select this surface in this location 

TOP 

 
FRONT
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DTM1

A_1 

A_2 
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• Click Insert, Model Datum, Axis or click the icon 

• In the graphics area, drag each of the two ‘drag handles’ and ‘snap’ them onto the 
RIGHT datum plane and the FRONT datum plane 

• Double click the dimension to the RIGHT datum and enter < 10.5 > for the value 

• Double click the dimension to the FRONT datum and enter < 11.5 > for the value 

• Click OK in the Datum Axis dialog box 

• The result is shown below (A_1) 

• Save the part 

• Click File, Close Window 

Task 4: Create a datum curve feature in 4455-009. 

• Open the part ‘4455-009.prt’ 

• Click View, Orientation, Standard Orientation  

• Click the Sketch icon 

• Select this surface for the sketch plane 

• Click Sketch in the Sketch dialog box or click the middle mouse button 

 

 

TOP 

FRONT 

RIGHT 

A_1 
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• Sketch a vertical centerline aligned with the RIGHT datum plane as shown below 

• Sketch and dimension two equal size symmetrical rectangles as shown below 

• Modify the dimension values as shown above 

• Click the checkmark to complete the sketch 

• Click View, Orientation, Standard Orientation  

• The result is shown below 

• Save the part  

• Click File, Close Window 

 Vertical centerline
aligned with RIGHT

FRONT 

RIGHT
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Task 5: Create datum features in 4455-207. 

• Open the part called ‘4455-207.prt’ 

• Select the TOP datum plane 

• Click Insert, Model Datum, Axis or click the icon 

• Click Offset References in the RMB popup menu 

• Select the RIGHT datum plane and the FRONT datum plane 

• Double click the dimension to the RIGHT datum and enter < -10 > for the value 

• Double click the dimension to the FRONT datum and enter < 22.5 > for the value 

• Click OK in the Datum Axis dialog box 

• In the model tree, select RIGHT and A_1 

• Click Insert, Model Datum, Plane or click the icon 

• Enter < -30 > for the angle dimension 

• Click OK in the Datum Plane dialog box 

• The result is shown below 

• Save the part  

• Click File, Close Window 

 

TOPFRONT

RIGHT 
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Task 6: Create a datum coordinate system. 

• Click File, Open or click the icon 

• Double click the ‘basic’ folder 

• Double click the ‘labs’ folder 

• Double click the part called ‘4455-302.prt’ 

• Set the selection filter to Geometry 

• Select this surface of the part first 

• Press and hold the CTRL key and then 
select this surface second 

• Press and hold the CTRL key and then 
select the bottom surface of the part 

• Click Insert, Model Datum, Datum 
Coordinate System or click the icon 

• In the Coordinate System dialog box, click the 
Orientation tab and click Flip in the X and Y as 
shown below 

XY 

Z 

The purpose of this task 
is to create a datum 
coordinate system, 

oriented this direction 
on this vertex

 

Click Orientation

Click Flip

Click Flip
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• In the Coordinate System dialog box, click the Properties tab 

• Enter < export > for the name of the coordinate system 

• Click OK in the dialog box  

• The result is shown below 

• Save the part 

• Click File, Close Window 

Task 7: Use the hide command. 

• Click File, Open or click the icon 

• Double click the ‘basic’ folder, then double click the ‘labs’ folder 

• Double click the part called ‘4455-303.prt’ 

• Select the RIGHT datum plane 

• Click View, Visibility, Hide 

• Select the TOP datum plane then click Hide in the RMB popup menu 

• Notice the icon used in the model tree for the hidden features 

• Click View, Visibility, Save Status 

• Read the message in the message area 

• Save the part 

Note 

The Save Status command forces hidden items to remain hidden after the 
part is saved and re-opened. 

EXPORT 
Y X

Z 

PRT_CSYS_DEF Y

XZ 



Datum Features Pro/ENGINEER Wildfire 5.0 Basic Design 

 

Page 160  COPYRIGHT  2009 CADQUEST INC. 

Task 8: Turn off the display of the datum name tags. 

• Be sure the datum planes, axes, points, and coordinate systems are displayed 

• Click View, Display Settings, Datum Display 

• Remove the checkmarks next to the name tags as shown below 

• Click OK in the Datum Display dialog box 

• Notice the datum name tags are not displayed 

• Click File, Close Window 

• Click File, Exit then click Yes 

 

Remove the checkmarks 
next to all the name tags 


